Skip to content

Error while trying to create a volume from a volume snapshot that sometimes result in snapshot loss #9538

Description

@winterhazel
ISSUE TYPE
  • Bug Report
COMPONENT NAME
KVM, Volume Snapshot
CLOUDSTACK VERSION
4.19.1.0
CONFIGURATION
OS / ENVIRONMENT

1 Zone, 1 Pod, 1 Cluster
Advanced networking
1 KVM host (Ubuntu 24.04)
1 Management Server (Ubuntu 24.04)
NFS primary storage

SUMMARY

Trying to create a volume from a volume snapshot results in an error that sometimes removes the snapshot.

STEPS TO REPRODUCE

When snapshot.backup.to.secondary is disabled, the following procedure sometimes results in an error at the last step:

  1. Take volume snapshot A of VM X
  2. Take volume snapshot B of VM X
  3. Create a volume from snapshot A
  4. Create a volume from snapshot B

When this happens, the second volume is not created, and sometimes volume snapshot B is removed from the primary storage.

EXPECTED RESULTS
Volume is created from volume snapshot
ACTUAL RESULTS
Volume is not created, and the snapshot is sometimes lost

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Type

Projects

Relationships

None yet

Development

No branches or pull requests

Issue actions