ISSUE TYPE
COMPONENT NAME
CLOUDSTACK VERSION
CONFIGURATION
OS / ENVIRONMENT
1 Zone, 1 Pod, 1 Cluster
Advanced networking
1 KVM host (Ubuntu 24.04)
1 Management Server (Ubuntu 24.04)
NFS primary storage
SUMMARY
Trying to create a volume from a volume snapshot results in an error that sometimes removes the snapshot.
STEPS TO REPRODUCE
When snapshot.backup.to.secondary is disabled, the following procedure sometimes results in an error at the last step:
- Take volume snapshot A of VM X
- Take volume snapshot B of VM X
- Create a volume from snapshot A
- Create a volume from snapshot B
When this happens, the second volume is not created, and sometimes volume snapshot B is removed from the primary storage.
EXPECTED RESULTS
Volume is created from volume snapshot
ACTUAL RESULTS
Volume is not created, and the snapshot is sometimes lost
ISSUE TYPE
COMPONENT NAME
CLOUDSTACK VERSION
CONFIGURATION
OS / ENVIRONMENT
1 Zone, 1 Pod, 1 Cluster
Advanced networking
1 KVM host (Ubuntu 24.04)
1 Management Server (Ubuntu 24.04)
NFS primary storage
SUMMARY
Trying to create a volume from a volume snapshot results in an error that sometimes removes the snapshot.
STEPS TO REPRODUCE
When
snapshot.backup.to.secondaryis disabled, the following procedure sometimes results in an error at the last step:When this happens, the second volume is not created, and sometimes volume snapshot B is removed from the primary storage.
EXPECTED RESULTS
ACTUAL RESULTS