Skip to content

Bump postcss-selector-parser from 6.1.2 to 6.1.5 - #404

Merged
kingthorin merged 1 commit into
mainfrom
dependabot/npm_and_yarn/postcss-selector-parser-6.1.5
Oct 27, 2026
Merged

kingthorin merged 1 commit into
mainfrom
dependabot/npm_and_yarn/postcss-selector-parser-6.1.5

Conversation

@dependabot

@dependabot dependabot Bot commented on behalf of github Oct 26, 2026

Copy link
Copy Markdown
Contributor

Bumps postcss-selector-parser from 6.1.2 to 6.1.5.

Release notes

Sourced from postcss-selector-parser's releases.

6.1.5

The 6.x line is now in security-only maintenance

This release exists because the advisory above covers every published 6.x version, and until now the only remediation on offer was an upgrade to 7.x. 6.1.5 is the patched version for the 6.x line.

The line is kept alive for the installed base that cannot move to 7 yet, Tailwind CSS 3 in particular, which depends on ^6.1.2. From here on it receives security fixes only: no features, no other bug fixes, no type changes. Everything else goes to 7.x, where this package is actively developed. Tailwind CSS 4 no longer depends on this package at all, so this line is expected to retire on its own.

6.1.5 is published under the legacy-v6 npm dist-tag, so npm install postcss-selector-parser keeps resolving to 7.x. Existing ^6 ranges pick up 6.1.5 as usual.

6.1.4

  • fix: tolerate non-node children when serializing selectors

6.1.3

Changelog

Sourced from postcss-selector-parser's changelog.

6.1.5 - 2026-10-19

The 6.x line is now in security-only maintenance

This release exists because the advisory above covers every published 6.x version, and until now the only remediation on offer was an upgrade to 7.x. 6.1.5 is the patched version for the 6.x line.

The line is kept alive for the installed base that cannot move to 7 yet, Tailwind CSS 3 in particular, which depends on ^6.1.2. From here on it receives security fixes only: no features, no other bug fixes, no type changes. Everything else goes to 7.x, where this package is actively developed. Tailwind CSS 4 no longer depends on this package at all, so this line is expected to retire on its own.

6.1.5 is published under the legacy-v6 npm dist-tag, so npm install postcss-selector-parser keeps resolving to 7.x. Existing ^6 ranges pick up 6.1.5 as usual.

6.1.4 - 2026-06-11

  • fix: tolerate non-node children when serializing selectors

6.1.3 - 2026-06-11

Commits
Maintainer changes

This version was pushed to npm by moox, a new releaser for postcss-selector-parser since your current version.


Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot show <dependency name> ignore conditions will show all of the ignore conditions of the specified dependency
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    You can disable automated security fix PRs for this repo from the Security Alerts page.

Bumps [postcss-selector-parser](https://github.com/postcss/postcss-selector-parser) from 6.1.2 to 6.1.5.
- [Release notes](https://github.com/postcss/postcss-selector-parser/releases)
- [Changelog](https://github.com/postcss/postcss-selector-parser/blob/6.1.5/CHANGELOG.md)
- [Commits](postcss/postcss-selector-parser@v6.1.2...6.1.5)

---
updated-dependencies:
- dependency-name: postcss-selector-parser
  dependency-version: 6.1.5
  dependency-type: indirect
...

Signed-off-by: dependabot[bot] <support@github.com>
@dependabot dependabot Bot added dependencies Pull requests that update a dependency file javascript Pull requests that update Javascript code labels Oct 26, 2026
@psiinon

psiinon commented Oct 26, 2026

Copy link
Copy Markdown
Member

Logo
Checkmarx One – Scan Summary & Details – 48caa013-369c-45e1-8211-82cd0a93353f


Fixed Issues (2) Great job! The following issues were fixed in this Pull Request

Severity: 2 Low

Severity Issue Source File / Package
LOW CVE-2026-9358 Npm-postcss-selector-parser-6.1.2
LOW CVE-2026-9358 Npm-postcss-selector-parser-7.1.0

Use @Checkmarx to take action directly from this PR:

  • Rescan the PR

Try it: @Checkmarx how can you help? · @Checkmarx rescan this PR

@kingthorin
kingthorin merged commit 3cad356 into main Oct 27, 2026
10 of 14 checks passed
@dependabot
dependabot Bot deleted the dependabot/npm_and_yarn/postcss-selector-parser-6.1.5 branch October 27, 2026 11:11
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

dependencies Pull requests that update a dependency file javascript Pull requests that update Javascript code

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants